re = /^([A-Z][a-z]+)+((__([a-z]+[A-Z]?)+)(--([a-z]+[A-Z]?)+)?)?$/
str = 'TitleCaseName
TitleCaseName__element
TitleCaseName__element--modifier
TitleCaseName--modifier
TitleCaseName__element__modifier'
# Print the match result
str.match(re) do |match|
puts match.to_s
end