package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([A-Z][a-z]+)+((__([a-z]+[A-Z]?)+)(--([a-z]+[A-Z]?)+)?)?$`)
var str = `TitleCaseName
TitleCaseName__element
TitleCaseName__element--modifier
TitleCaseName--modifier
TitleCaseName__element__modifier`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}