re = /^(-?\d+)(,?\d+)*(\.\d+(e\d+)?)?$/m
str = '123,340.00
1.9e10
125
-255.34
3.14529
720p'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end