package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(-?\d+)(,?\d+)*(\.\d+(e\d+)?)?$`)
var str = `123,340.00
1.9e10
125
-255.34
3.14529
720p`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}