using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(-?\d+)(,?\d+)*(\.\d+(e\d+)?)?$";
string input = @"123,340.00
1.9e10
125
-255.34
3.14529
720p";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}