const regex = /^(-?\d+)(,?\d+)*(\.\d+(e\d+)?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(-?\\d+)(,?\\d+)*(\\.\\d+(e\\d+)?)?$', 'gm')
const str = `123,340.00
1.9e10
125
-255.34
3.14529
720p`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}