// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\{\w+:array,\w+,\w+,([^}]+?),([^}]+?)\}|\{\w+:(int|float),([^}]+?),([^}]+?)\}").unwrap();
let string = "{n:int,1,50}
{a:array,n,int,1,1e8}
{b:array,n,int,1,1e8}
{n:int,1,1e5} {k:int,0,min(n-1,10)}
{p:array,n,int,1,1e9}
{c:array,n,int,0,1e9}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}