$re = '/\{\w+:array,\w+,\w+,([^}]+?),([^}]+?)\}|\{\w+:(int|float),([^}]+?),([^}]+?)\}/m';
$str = '{n:int,1,50}
{a:array,n,int,1,1e8}
{b:array,n,int,1,1e8}
{n:int,1,1e5} {k:int,0,min(n-1,10)}
{p:array,n,int,1,1e9}
{c:array,n,int,0,1e9}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);