# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{\w+:array,\w+,\w+,([^}]+?),([^}]+?)\}|\{\w+:(int|float),([^}]+?),([^}]+?)\}"
test_str = ("{n:int,1,50}\n"
"{a:array,n,int,1,1e8}\n"
"{b:array,n,int,1,1e8}\n\n"
"{n:int,1,1e5} {k:int,0,min(n-1,10)}\n"
"{p:array,n,int,1,1e9}\n"
"{c:array,n,int,0,1e9}\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.