import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\w+:array,\\w+,\\w+,([^\\}]+?),([^\\}]+?)\\}|\\{\\w+:(int|float),([^\\}]+?),([^\\}]+?)\\}";
final String string = "{n:int,1,50}\n"
+ "{a:array,n,int,1,1e8}\n"
+ "{b:array,n,int,1,1e8}\n\n"
+ "{n:int,1,1e5} {k:int,0,min(n-1,10)}\n"
+ "{p:array,n,int,1,1e9}\n"
+ "{c:array,n,int,0,1e9}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}