re = /{HubRegEx\[\((.)(\d*)\)]}/
str = 'blahblah{HubRegEx[(|5)]}blahblah|blah{HubRegEx[(|20)]}blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end