package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{HubRegEx\[\((.)(\d*)\)]}`)
var str = `blahblah{HubRegEx[(|5)]}blahblah|blah{HubRegEx[(|20)]}blah`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}