$re = '/{HubRegEx\[\((.)(\d*)\)]}/';
$str = 'blahblah{HubRegEx[(|5)]}blahblah|blah{HubRegEx[(|20)]}blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);