using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{HubRegEx\[\((.)(\d*)\)]}";
string input = @"blahblah{HubRegEx[(|5)]}blahblah|blah{HubRegEx[(|20)]}blah";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}