import Foundation
let pattern = #"(^|\s)([0-9]{4}|[0-9]{6}|[0-9]{8})(\s|\.|,)[^0-9]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"Dear Customer, OTP to login to SBI Internet banking(Personal) is 12343212. Do not share with anyone. -SBI"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)