$re = '/(^|\s)([0-9]{4}|[0-9]{6}|[0-9]{8})(\s|\.|,)[^0-9]/i';
$str = 'Dear Customer, OTP to login to SBI Internet banking(Personal) is 12343212. Do not share with anyone. -SBI';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);