re = /(^|\s)([0-9]{4}|[0-9]{6}|[0-9]{8})(\s|\.|,)[^0-9]/i
str = 'Dear Customer, OTP to login to SBI Internet banking(Personal) is 12343212. Do not share with anyone. -SBI'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end