use strict;
my $str = 'Dear Customer, OTP to login to SBI Internet banking(Personal) is 12343212. Do not share with anyone. -SBI';
my $regex = qr/(^|\s)([0-9]{4}|[0-9]{6}|[0-9]{8})(\s|\.|,)[^0-9]/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}