$re = '/_[a-z]+_[a-z]+_\d{8}_\d*_/i';
$str = '_HAM_MUC_24022017_100_
_HAM_MUC_24022017_100_
_gaexp
_gat_UA-35638432-1
intercom-id-c5ke8zbr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);