use strict;
my $str = '_HAM_MUC_24022017_100_
_HAM_MUC_24022017_100_
_gaexp
_gat_UA-35638432-1
intercom-id-c5ke8zbr';
my $regex = qr/_[a-z]+_[a-z]+_\d{8}_\d*_/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}