#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)_[a-z]+_[a-z]+_\d{8}_\d*_"
Local $sString = "_HAM_MUC_24022017_100_" & @CRLF & _
"_HAM_MUC_24022017_100_" & @CRLF & _
"_gaexp" & @CRLF & _
"_gat_UA-35638432-1" & @CRLF & _
"intercom-id-c5ke8zbr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")