import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "_[a-z]+_[a-z]+_\\d{8}_\\d*_";
final String string = "_HAM_MUC_24022017_100_\n"
+ "_HAM_MUC_24022017_100_\n"
+ "_gaexp\n"
+ "_gat_UA-35638432-1\n"
+ "intercom-id-c5ke8zbr";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}