import Foundation
let pattern = #"^(?<INUSE>[* ]):(?<BSSID>(?<BSSID0>[0-9A-F]{2}):(?<BSSID1>[0-9A-F]{2}):(?<BSSID2>[0-9A-F]{2}):(?<BSSID3>[0-9A-F]{2}):(?<BSSID4>[0-9A-F]{2}):(?<BSSID5>[0-9A-F]{2})):(?<SSID>.*?(?=:)):(?<MODE>.*?(?=:)):(?<CHAN>.*?(?=:)):(?<RATE>.*?(?=:)):(?<SIGNAL>\d{1,3}(?=:)):(?<BARS>.*?(?=:)):(?<SECURITY>.*?(?=:)):(?<FREQ>.*?(?=:)):(?<DEVICE>.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" :EA:55:A8:2C:DA:3A:my-wifi-ssid:Infra:11:130 Mbit/s:92:▂▄▆█:WPA2:2462 MHz:wlp2s0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)