using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<INUSE>[* ]):(?<BSSID>(?<BSSID0>[0-9A-F]{2}):(?<BSSID1>[0-9A-F]{2}):(?<BSSID2>[0-9A-F]{2}):(?<BSSID3>[0-9A-F]{2}):(?<BSSID4>[0-9A-F]{2}):(?<BSSID5>[0-9A-F]{2})):(?<SSID>.*?(?=:)):(?<MODE>.*?(?=:)):(?<CHAN>.*?(?=:)):(?<RATE>.*?(?=:)):(?<SIGNAL>\d{1,3}(?=:)):(?<BARS>.*?(?=:)):(?<SECURITY>.*?(?=:)):(?<FREQ>.*?(?=:)):(?<DEVICE>.*)";
string input = @" :EA:55:A8:2C:DA:3A:my-wifi-ssid:Infra:11:130 Mbit/s:92:▂▄▆█:WPA2:2462 MHz:wlp2s0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}