use strict;
my $str = ' :EA:55:A8:2C:DA:3A:my-wifi-ssid:Infra:11:130 Mbit/s:92:▂▄▆█:WPA2:2462 MHz:wlp2s0';
my $regex = qr/^(?<INUSE>[* ]):(?<BSSID>(?<BSSID0>[0-9A-F]{2}):(?<BSSID1>[0-9A-F]{2}):(?<BSSID2>[0-9A-F]{2}):(?<BSSID3>[0-9A-F]{2}):(?<BSSID4>[0-9A-F]{2}):(?<BSSID5>[0-9A-F]{2})):(?<SSID>.*?(?=:)):(?<MODE>.*?(?=:)):(?<CHAN>.*?(?=:)):(?<RATE>.*?(?=:)):(?<SIGNAL>\d{1,3}(?=:)):(?<BARS>.*?(?=:)):(?<SECURITY>.*?(?=:)):(?<FREQ>.*?(?=:)):(?<DEVICE>.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}