re = /^(?<INUSE>[* ]):(?<BSSID>(?<BSSID0>[0-9A-F]{2}):(?<BSSID1>[0-9A-F]{2}):(?<BSSID2>[0-9A-F]{2}):(?<BSSID3>[0-9A-F]{2}):(?<BSSID4>[0-9A-F]{2}):(?<BSSID5>[0-9A-F]{2})):(?<SSID>.*?(?=:)):(?<MODE>.*?(?=:)):(?<CHAN>.*?(?=:)):(?<RATE>.*?(?=:)):(?<SIGNAL>\d{1,3}(?=:)):(?<BARS>.*?(?=:)):(?<SECURITY>.*?(?=:)):(?<FREQ>.*?(?=:)):(?<DEVICE>.*)/m
str = ' :EA:55:A8:2C:DA:3A:my-wifi-ssid:Infra:11:130 Mbit/s:92:▂▄▆█:WPA2:2462 MHz:wlp2s0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end