re = /{[ \t]*foreach[ \t]*\$(_*[A-Za-z]+[A-Za-z0-9_]*)[ \t]*as[ \t]*\$(_*[A-Za-z]+[A-Za-z0-9_]*)(?:[ \t]=>[ \t]*\$(_*[A-Za-z]+[A-Za-z0-9_]*))?[ \t]*}(.*){[ \t]*\/foreach[ \t]*}/i
str = '{foreach $groups as $name => $val} FFFFFFFFFFFFF {/foreach}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end