#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?Uis){[ \t]*foreach[ \t]*\$(_*[A-Za-z]+[A-Za-z0-9_]*)[ \t]*as[ \t]*\$(_*[A-Za-z]+[A-Za-z0-9_]*)(?:[ \t]=>[ \t]*\$(_*[A-Za-z]+[A-Za-z0-9_]*))?[ \t]*}(.*){[ \t]*\/foreach[ \t]*}"
Local $sString = "{foreach $groups as $name => $val} FFFFFFFFFFFFF {/foreach}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")