import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{[ \\t]*foreach[ \\t]*\\$(_*[A-Za-z]+[A-Za-z0-9_]*)[ \\t]*as[ \\t]*\\$(_*[A-Za-z]+[A-Za-z0-9_]*)(?:[ \\t]=>[ \\t]*\\$(_*[A-Za-z]+[A-Za-z0-9_]*))?[ \\t]*\\}(.*)\\{[ \\t]*\\/foreach[ \\t]*\\}";
final String string = "{foreach $groups as $name => $val} FFFFFFFFFFFFF {/foreach}";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}