$re = '/{[ \t]*foreach[ \t]*\$(_*[A-Za-z]+[A-Za-z0-9_]*)[ \t]*as[ \t]*\$(_*[A-Za-z]+[A-Za-z0-9_]*)(?:[ \t]=>[ \t]*\$(_*[A-Za-z]+[A-Za-z0-9_]*))?[ \t]*}(.*){[ \t]*\/foreach[ \t]*}/Uis';
$str = '{foreach $groups as $name => $val} FFFFFFFFFFFFF {/foreach}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);