import Foundation
let pattern = #"(http(s)?://www.)?((flipkart(?:.com)+([^\s\.]+[^\s]*)+[^,.\s]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://www.flipkart.com/sansui-pro-view-102cm-40-inch-full-hd-led-tv-2019/p/itmfg2fyuschpzha?pid=TVSFG2FYGQG8MCWK&affid=extinr&affExtParam1=mbu511967417_34289009_65"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)