using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http(s)?://www.)?((flipkart(?:.com)+([^\s\.]+[^\s]*)+[^,.\s]))";
string input = @"https://www.flipkart.com/sansui-pro-view-102cm-40-inch-full-hd-led-tv-2019/p/itmfg2fyuschpzha?pid=TVSFG2FYGQG8MCWK&affid=extinr&affExtParam1=mbu511967417_34289009_65";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}