const regex = new RegExp('(http(s)?://www.)?((flipkart(?:.com)+([^\\s\\.]+[^\\s]*)+[^,.\\s]))', 'gm')
const str = `https://www.flipkart.com/sansui-pro-view-102cm-40-inch-full-hd-led-tv-2019/p/itmfg2fyuschpzha?pid=TVSFG2FYGQG8MCWK&affid=extinr&affExtParam1=mbu511967417_34289009_65`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}