#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(http(s)?://www.)?((flipkart(?:.com)+([^\s\.]+[^\s]*)+[^,.\s]))"
Local $sString = "https://www.flipkart.com/sansui-pro-view-102cm-40-inch-full-hd-led-tv-2019/p/itmfg2fyuschpzha?pid=TVSFG2FYGQG8MCWK&affid=extinr&affExtParam1=mbu511967417_34289009_65"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")