import Foundation
let pattern = #"(?<IsNumeric>^[+-]?([1-9]*|[1-9]{1,3}(,\d{3})*|[0]*)(\.\d+)?)\b$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0.3
1
3
000691965
1,324,125.03
0,324,125.03
-1,324,125.03
abcd123
1.2.5
1234abc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)