// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<IsNumeric>^[+-]?([1-9]*|[1-9]{1,3}(,\d{3})*|[0]*)(\.\d+)?)\b$").unwrap();
let string = "0.3
1
3
000691965
1,324,125.03
0,324,125.03
-1,324,125.03
abcd123
1.2.5
1234abc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}