use strict;
my $str = '0.3
1
3
000691965
1,324,125.03
0,324,125.03
-1,324,125.03
abcd123
1.2.5
1234abc';
my $regex = qr/(?<IsNumeric>^[+-]?([1-9]*|[1-9]{1,3}(,\d{3})*|[0]*)(\.\d+)?)\b$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}