import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<IsNumeric>^[+-]?([1-9]*|[1-9]{1,3}(,\\d{3})*|[0]*)(\\.\\d+)?)\\b$";
final String string = "0.3\n"
+ "1\n"
+ "3\n"
+ "000691965\n"
+ "1,324,125.03\n"
+ "0,324,125.03\n"
+ "-1,324,125.03\n"
+ "abcd123\n"
+ "1.2.5\n"
+ "1234abc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}