// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*\d+\-\d{2}\.\d{4}\.\d\.\d{2}\.\d{4}\s*").unwrap();
let string = " Processo nº: 0002192-73.2007.8.05.0250";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}