package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*\d+\-\d{2}\.\d{4}\.\d\.\d{2}\.\d{4}\s*`)
var str = ` Processo nº: 0002192-73.2007.8.05.0250`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}