using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\d+\-\d{2}\.\d{4}\.\d\.\d{2}\.\d{4}\s*";
string input = @" Processo nº: 0002192-73.2007.8.05.0250";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}