$re = '/\s*\d+\-\d{2}\.\d{4}\.\d\.\d{2}\.\d{4}\s*/m';
$str = ' Processo nº: 0002192-73.2007.8.05.0250';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);