import Foundation
let pattern = #"(?:w+])*(?:[x84])(?<li>[\s\S]*?[;.])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Faire cheminer les modifications règlementaires selon les différentes instances (processus de gouvernance) :
Approbation du principe de révision réglementaire par le comité de direction;
Approbation des orientations par le CA;
Consultation de la nouvelle règlementation auprès du CFPIC (avis);
Approbation et adoption de la nouvelle règlementation par le CA;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)