#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:w+])*(?:[x84])(?<li>[\s\S]*?[;.])"
Local $sString = "Faire cheminer les modifications règlementaires selon les différentes instances (processus de gouvernance) :" & @CRLF & _
" Approbation du principe de révision réglementaire par le comité de direction;" & @CRLF & _
" Approbation des orientations par le CA;" & @CRLF & _
" Consultation de la nouvelle règlementation auprès du CFPIC (avis);" & @CRLF & _
" Approbation et adoption de la nouvelle règlementation par le CA;" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")