$re = '/<a\s*(?:href=[\'"]([^\'"]+)[\'"])?\s*(?:title=[\'"]([^\'"]+)[\'"])?.*?>((?:(?!<\/a>).)*)<\/a>/i';
$str = '<a href="/test1" title="da">test</a>
<a href="//stackoverflow.com">current community</a>
dwadwad<a href="/test2" title="adwa">test2</a>213213
<a href="/test2" title="adwa">test2</a>ed<a href="/test3">test2</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);