using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s*(?:href=[\'""]([^\'""]+)[\'""])?\s*(?:title=[\'""]([^\'""]+)[\'""])?.*?>((?:(?!<\/a>).)*)<\/a>";
string input = @"<a href=""/test1"" title=""da"">test</a>
<a href=""//stackoverflow.com"">current community</a>
dwadwad<a href=""/test2"" title=""adwa"">test2</a>213213
<a href=""/test2"" title=""adwa"">test2</a>ed<a href=""/test3"">test2</a>
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}