import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s*(?:href=[\\'\"]([^\\'\"]+)[\\'\"])?\\s*(?:title=[\\'\"]([^\\'\"]+)[\\'\"])?.*?>((?:(?!<\\/a>).)*)<\\/a>";
final String string = "<a href=\"/test1\" title=\"da\">test</a> \n"
+ "<a href=\"//stackoverflow.com\">current community</a>\n"
+ "dwadwad<a href=\"/test2\" title=\"adwa\">test2</a>213213\n"
+ "<a href=\"/test2\" title=\"adwa\">test2</a>ed<a href=\"/test3\">test2</a>\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}