const regex = /<a\s*(?:href=[\'"]([^\'"]+)[\'"])?\s*(?:title=[\'"]([^\'"]+)[\'"])?.*?>((?:(?!<\/a>).)*)<\/a>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a\\s*(?:href=[\\\'"]([^\\\'"]+)[\\\'"])?\\s*(?:title=[\\\'"]([^\\\'"]+)[\\\'"])?.*?>((?:(?!<\\\/a>).)*)<\\\/a>', 'gi')
const str = `<a href="/test1" title="da">test</a>
<a href="//stackoverflow.com">current community</a>
dwadwad<a href="/test2" title="adwa">test2</a>213213
<a href="/test2" title="adwa">test2</a>ed<a href="/test3">test2</a>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}