$re = '/\w+ \w+ \(OBJECT\) \@[a-z0-9]+/m';
$str = 'SCALAR_NaN ceil (SCALAR_NaN) @7ff710295590
SCALAR waypointVisible (ARRAY) @7ff70f56e030
NOTHING enableSatNormalOnDetail (BOOL) @7ff70f1a0d90
ARRAY getPosATL (OBJECT) @7ff70f1e9df0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);