using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+ \w+ \(OBJECT\) \@[a-z0-9]+";
string input = @"SCALAR_NaN ceil (SCALAR_NaN) @7ff710295590
SCALAR waypointVisible (ARRAY) @7ff70f56e030
NOTHING enableSatNormalOnDetail (BOOL) @7ff70f1a0d90
ARRAY getPosATL (OBJECT) @7ff70f1e9df0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}